Security alert

bobmac

Major Champion
Joined
Feb 2, 2009
Messages
27,785
Location
Lincolnshire
Visit site
Never.
Maybe you have your security settings turned full up
Do a search for Internet settings then select security settings then turn it down a touch to medium high.
HTH
 
Top